Issue accessing Akuity Platform Portal
Incident Report for
Akuity
Resolved
This incident has been resolved.
Posted
Mar
25
,
2026
-
16:34
UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Mar
25
,
2026
-
16:27
UTC
Update
The issue has been identified, and the Akuity Platform portal is now operational. We will continue to monitor the system.
Posted
Mar
25
,
2026
-
16:26
UTC
Investigating
We are currently investigating an issue preventing access to the Akuity Platform Portal.
Posted
Mar
25
,
2026
-
16:11
UTC
This incident affected: Akuity Platform.
×
Subscribe to Incident
Subscribe to updates for
Issue accessing Akuity Platform Portal
via . You'll receive .